The Copyright of this manual is held by uib gmbh in Mainz, Germany.

This manual is published under the creative commons license
'Attribution - ShareAlike' (by-sa).

CC by sa

A description of the license can be found here:
https://creativecommons.org/licenses/by-sa/3.0/

The legally binding text of the license can be found here:
https://creativecommons.org/licenses/by-sa/3.0/legalcode

Most parts of the opsi software is open source.
Not open source are the parts of the source code which contain new extensions, that are still under cofunding, which have not been paid off yet. See also: opsi cofunding projects

All of the open source code is published under the AGPLv3.

agplv3

The legally binding text of the AGPLv3 license can be found here: http://www.gnu.org/licenses/agpl-3.0-standalone.html

Information about the AGPL: http://www.gnu.org/licenses/agpl-3.0.en.html

For licenses to use opsi in the context of closed source software, please contact uib gmbh.

The names 'opsi', 'opsi.org', 'open pc server integration' and the opsi logo are registered trademarks of uib gmbh.

2. opsi supportmatrix opsi version 4.2 / 4.1

2.1. opsi Support Matrix

This is an overview about which platforms are supported to by opsi for running as a server or client.

2.2. Supported distributions for server

Distribution

Opsi 4.2

Debian 11 Bullseye

supported

Debian 10 Buster

supported

Debian 9 Stretch

supported

Ubuntu 22.04 LTS Jammy Jellyfish

supported

Ubuntu 20.04 LTS Focal Fossa

supported

Ubuntu 18.04 LTS Bionic Beaver

supported

Ubuntu 16.04 LTS Xenial Xerus

unsupported

RHEL 8

supported

RHEL 7

unsupported

CentOS 8

discontinued

CentOS 7

unsupported

Alma Linux 8

supported

Rocky Linux 8

supported

SLES 15 SP1

supported

SLES 15 SP2

supported

SLES 15 SP3

supported

SLES 12SP*

unsupported

SLES 12

unsupported

openSuse Leap 15-3

supported

openSuse Leap 15-2

discontinued

openSuse Leap 15-1

discontinued

openSuse Leap 15

discontinued

UCS 4.4

supported

UCS 5.0

supported

supported: Supported unsupported: Unsupported develop: Under development discontinued: Discontinued

2.2.1. Supported as opsi-client: Windows

Windows Version

Opsi 4.2

Opsi 4.1

Windows 11

supported

Windows 2022

supported

Windows 10

supported

supported

Windows 2019

supported

supported

Windows 2016

supported

supported

Windows 2012 R2

supported

supported

Windows 8.1

supported

supported

Windows 2012

supported

supported

Windows 8

discontinued

discontinued

Windows 2008 R2

supported

supported

Windows 7

supported

supported

Windows 2008

discontinued

discontinued

Windows Vista

discontinued

discontinued

Windows 2003

discontinued

discontinued

Windows XP

discontinued

discontinued

Windows 2000

discontinued

discontinued

supported: Supported unsupported: Unsupported develop: Under development discontinued: Discontinued

2.2.2. Supported as opsi-client: Linux

Table 1. Supported Linux OS as Client in opsi 4.2 and 4.1 / Unterst├╝tzte Linux-OS als Client in opsi 4.2 und 4.1

Distribution

OS-Installation

netboot products

client-agent

opsiclientd

Debian 11 Bullseye

supported

debian, debian11

supported

supported

Debian 10 Buster

supported

debian, debian10

supported

supported

Debian 9 Stretch

supported

debian, debian9

supported

supported

Debian 8 Jessie

discontinued

debian, debian8

discontinued

discontinued

Ubuntu Bionic 20.04 LTS

supported

ubuntu, ubuntu20-04

supported

supported

Ubuntu Bionic 18.04 LTS

supported

ubuntu, ubuntu18-04

supported

supported

Ubuntu Xenial 16.04 LTS

discontinued

ubuntu, ubuntu16-04

discontinued

discontinued

Ubuntu Trusty 14.04 LTS

discontinued

ubuntu, ubunt14-04

discontinued

discontinued

Linux Mint 20-3

supported

mint20-3

supported

supported

Linux Mint 20-2

supported

mint20-2

supported

supported

Linux mint 20-1

supported

mint20-1

supported

supported

RHEL 8

supported

rhel8

supported

supported

RHEL 7

supported

rhel70

supported

supported

RHEL 6

discontinued

Alma Linux 8

supported

alma8

supported

supported

Rocky Linux 8

supported

rocky8

supported

supported

CentOS 8

discontinued

centos8

discontinued

discontinued

CentOS 7

supported

centos70

supported

supported

CentOS 6

discontinued

SLES 15 SP3

supported

sles15sp3

supported

supported

SLES 15 SP2

supported

sles15sp2

supported

supported

SLES 15 SP1

supported

sles15sp1

supported

supported

SLES 12 SP5

supported

sles12sp5

supported

supported

SLES 12 SP4

supported

sles12sp4

supported

supported

SLES 12 SP3

supported

sles12sp3

supported

supported

SLES 12 SP2

discontinued

sles12sp2